Lorch

  1. Brad93

    Brad93 M J B Engineering

    Messages:
    8,885
    Location:
    Essex
    Fingers crossed it’s nothing too bad. How old is the machine? If the serial number has rubbed off it sounds like it’s had a hard life
     
  2. milentze New Member

    Messages:
    5
    Location:
    Bosnia
    Thank you Brad. Hope its nothing bad too. It`s 4 years old.
    Probably tomorow will start with disassemble. If we find the issue will write here for sure.
     
    slim_boy_fat and Brad93 like this.
  3. Brad93

    Brad93 M J B Engineering

    Messages:
    8,885
    Location:
    Essex
    Well worth getting fixed then at only 4 years old.
     
  4. matt1978

    matt1978 www.lorch.eu

    Messages:
    3,742
    Location:
    UK, Cannock
    Was it yours from new? Or preowned?

    Surely at 4 years old the serial number and data plate should still be visable?
     
    Richard. and Brad93 like this.
  5. milentze New Member

    Messages:
    5
    Location:
    Bosnia
    It is mine but it's my fault for giving the machine to others to use and who knows where they are put it down so it is all scratched.

    For now it is diode on primary driver power unit. Somehow we managed to damage it. I have odered it and now wait.
    So, when we replace it then goes voltage measurement on pc board wich contains the welding logic-sequence control and process control of the machine.
    Diodes(4 of them) and IGBT(4 of them) on secondary rectifer are good and thanks god for that.
    So, thats it for now.
     
Advertisements