TradesMarc 151 wire speed issue

  1. stevieturbo Member

    Messages:
    71
    Location:
    Norn Iron
    I've had the machine from new, a longgg time ago.

    But intermittently, wire speed just doesnt play ball. It can run correctly for a few seconds, then slow down for a couple, then back to normal again. All at random.

    With no load, no weld....motor speed seems steady for as long as I hold the trigger though.

    However...with a scope on the motor ( 0-50v scale as attenuated 10:1 )

    Left side is a single trigger pull at a low wire speed. Right side is a single trigger pull with middle wire speed of the dial. No load, no weld test.
    Voltages are almost stable for a short while...then all over the place, then stable for a bit...then all over the place.

    murex motor test.jpg

    For comparison I tried the motor off a small 12v battery just to confirm scope operation etc.

    murex 12v battery test.jpg

    Board PCB

    DSC06156 (Large).jpeg

    Machine

    DSC06152 (Large).jpeg

    Likely something on the PCB at fault ? Or the motor itself ?

    Repair options ?

    I did replace the little rotary pot a few years back and the problem seemed to go away after that. But it's been doing it for a while now ( infrequent DIY use ). I tried another pot but it didnt seem to make a difference.

    Thanks

    Stevie
     
  2. eddie49 Member

    The PCB has a small transformer which produces a couple of Watts of 24v AC, but that only runs the on/off relay. Power for the wirefeed motor is tapped off the main welding power. That is a simple and cheap way to do it, better machines use a separate 24v DC power supply. I'm surprised Murex did it that way....

    The pulses that show on your scope trace are too fast to affect the motor or the wire speed. They probably come from the crude speed control on the PCB, which is trying to emulate a pulse-width-modulated ( PWM ) controller.

    I think that the variations in wirespeed are caused by variations in welding power. Do you notice any random weakness or changes in arc strength?
    I would start by checking all the connections in the high-current welding path - the thick secondary wires out of the transformer, the input to the rectifier, the inductor, the work return lead, etc. A lot of these connections will be bolted together and may look OK, but it's worth opening them and checking for corrosion on the wires and terminals.
    If that all looks OK, then I would suspect loose or burnt connections or contacts on the transformer primary circuit, especially the power range selection switch.

    Circuit diagram:
    murex_tradesmarc_151.pdf_2.png
     
  3. stevieturbo Member

    Messages:
    71
    Location:
    Norn Iron
    Thanks.

    The point of the traces.....take the left graph. It starts around 12v average...but then is varying from 12-18v or thereabouts....wire speed on the dial has not been touched. Then it drops back again to a more stable 12v...again, the dial has not been touched for the entirety of each trace.

    The same behaviour on the right graph. Voltage definitely fluctuates, but the dial for wire speed has not been touched from start to finish.

    When welding audibly I can hear the motor change tone, and when speed drops, it can no longer weld as wire feed is far too slow. It just doesnt do it all the time...it might run fine for a bit...then it does it intermittently. Or it might do it right from the first pull of the trigger.
    Just totally unpredictable.

    but when it does behave normally, welding is same as it has always been.

    I did check power coming out of the blue thing on the board....which I thought would have been DC, although it would almost appear to be 18v AC so that ties in with what you said on the board.

    But yes there is a smaller transformer at the front of the machine
     
  4. eddie49 Member

    The blue rectangular component is an encapsulated PCB-mounted transformer, usually 230v -> 24v AC. The output is normally half-wave or full-wave rectified to DC, and drives the power-on relay in the clear plastic case via the trigger switch.
    The wirefeed motor gets power from the output of the main welding transformer, via the speed controller on the PCB. During the welding process this voltage will vary, and using this simple method of power source can cause the wirespeed to decrease, which will cause the arc length to increase, the voltage across the arc will increase, the wirespeed will increase, etc. The usual end-result of this is that there is a stuttering start to the MIG process. Better-quality MIG machines ( which I thought Murex was ! ) avoid this by having a dedicated stabilised DC supply for the motor and the control circuitry. From the diagram above, the TradesMarc does not have this. The small transformer will be the inductor ( choke ).
    [ A common modification to improve low-end welders is to add a separate 20v - 24v DC supply, e.g. a laptop mains power adapter.]

    The motor speed controller may be a series-pass current source, a variable pulsed driver, or sometimes even an SCR. If you read the number off the power semiconductor ( black plastic rectangle with a metal mounting tab ) it will help to decide how the circuit works. The fault that you are seeing may be an electronic problem in the speed controller, which may be solved by replacing components, but without a circuit diagram that will take a bit of experimentation.

    What is the timebase of your scope traces above?
    When you test the motor, either on a battery or using the normal controller but not welding, do you hear or feel any speed variation if you load the pressure roller moderately with a gloved hand?
    Can you get to the internals of the wirefeed assembly easily, to check the gears, the grease and the bearings, and the motor brushes?
    Does the pressure roller ( normally a ball bearing ) rotate smoothly?
     
  5. stevieturbo Member

    Messages:
    71
    Location:
    Norn Iron
    That's the two transformers.

    two transformers.jpeg

    I did have a good poke about at all the connections, certainly everything feels good and tight, nothing pulled or strained etc. They've horrible wire coverings on a lot of them.
    I think I got it around 1994 or so, so it's lasted ok. ( ignore the crimps, they're mine when I had to add a gas solenoid when my original torch died, which controlled the gas flow actually at the torch itself. )

    Time base was recorded at 10ms, although that was purely as I was recording, I could probably filter it in the software after, although it's a pretty basic scope.

    All wire feed setup etc seems to work fine. Strangely....I got fed up and decided to put it all back together and record it whilst doing some welds.
    And typical....it's working fine now lol. Although the scope trace of voltages during welding look just as crap, but wire speed did remain steady throughout at low speeds and high, low current settings and higher.
    Also did some small repairs on the car ( i hate rust ) on regular thin panel and it seemed to work fine. TBH, it's working better now than it has for many months, so maybe have disturbed a connection somewhere.
    I did also hit it and the motor with the airline to blow away any crap.

    Thanks so far.....but I just know the current working scenario will be short lived lol.
     
Advertisements