Snap on 130 feed wire tensioner!

  1. Adee New Member

    Messages:
    5
    Location:
    Hampshire UK
    I finally got my Snap-on mig welder 130 turbo working after the wire feed tensioner broke.

    What a nightmare you can’t get these parts anywhere not even for the Cebora 130 turbo and BOC mig master 130, which I’ve been told have the same parts.

    So had to make my own


    Has any one else had this problem?
     
    • 0B9D9500-CC8D-4230-9750-C6834A437A82.jpeg
    • 7EB517F7-5F65-48B7-8B5C-E27E6905B664.jpeg
  2. gaz1

    gaz1 Member

    Messages:
    10,934
    Location:
    westyorkshire
    some others might have had that problem i am aware of other models faling on the wire tensioners though
     
  3. RonA

    RonA specialist in repairing sealed for life equipment

    Messages:
    1,583
    Location:
    Stockton on Tees, UK
    When my Cebora 130 wire feed failed, it was the pivot point that snapped off (too much tension I guess). Fortunately that was some time ago & then spares were still available via BOC.
    Would be very interested in to how you made the replacement feed roller holder.
    I made a little metal bracket which braced the pivot point to prevent it snapping off again.
    RonA
     
  4. Adee New Member

    Messages:
    5
    Location:
    Hampshire UK
    I modelled the part and then produced it on a DLP printer in ABS type material.
     
  5. Adee New Member

    Messages:
    5
    Location:
    Hampshire UK
    Here’s some better quality pics.
     
    • A2FED275-DEAB-4E71-AE18-C4787993C63B.jpeg
    • 433ECC62-376A-4E2E-90DA-30BCA22B2E29.jpeg
    Hopefuldave likes this.
  6. slim_boy_fat

    slim_boy_fat Forum Supporter

    @Adee Welcome aboard :waving: , and congratulations on your [fast] fix :thumbup:
     
  7. Adee New Member

    Messages:
    5
    Location:
    Hampshire UK
    Thank you for the welcome
     
  8. RonA

    RonA specialist in repairing sealed for life equipment

    Messages:
    1,583
    Location:
    Stockton on Tees, UK
    Very impressive, How did the original fail?
    The pivot point is a weak link, you may have to end up modelling that too.
    I’ve had problems with the feed on mine ever since I bought it, that was many years ago.
    There have been several threads on the forum about changing the feed mechanism for something more robust, been sorely tempted on many occasions to follow suit.
    RonA
     
  9. Adee New Member

    Messages:
    5
    Location:
    Hampshire UK
    Mine kept failing on the other end where the tensioner knob goes. Probably from where it had been left in the garage tensioned up for years☺️
     
  10. Onoff Member

    Messages:
    1,324
    Location:
    Sevenoaks, UK
    @Adee nice fix.

    I'm sitting here with a broken one, modelling a new one in AutoCAD and Google image searched for what the original should look like. Then I found this thread! :laughing:

    Any chance of posting up the .stp / .stl file or PM'ing it to me?


    Cebora Fix_7.JPG

    ABS I see. I've only been successful here in PLA so far.

    EDIT: Just found this on eBay. I presume it's you and you're selling them? I take it back ref asking for the files! :laughing: I've put the lad I was going to print it for onto your link.

    https://www.ebay.co.uk/itm/264722862023
     
Advertisements