Murex 130S

  1. Welder Wilk New Member

    Messages:
    13
    Location:
    Lincoln UK
    Good day fine people.
    So the welder was running fine after replacing the resistor on top of the contactor but after about 3 days the welder stopped re acting to the trigger input, so i remover the side case and with a length of wooden dowel I started to move wires around for a break or loose connection.
    After lots of messing about I found the if I just tapped the contactor it struck up as normal.
    The label on the side says it is a
    Klockner Moeller "DIL 00-52d "
    Am I able to still purchase one of these in the UK, I can find them in the USA.
    Any assistance with this would be good.
    Many Thanks
     
  2. MBB Forum Supporter

    Messages:
    1,127
    Location:
    northumberland
  3. eddie49 Member

    The contactor could just be sticky, perhaps due to dirt or magnetic dust inside. If you mark where all the connections go, it should be possible to remove it, strip it down and give it a good clean. You could also lightly polish the contacts, e.g. with Scotchbrite or 1000 grit wet & dry.
     
  4. Welder Wilk New Member

    Messages:
    13
    Location:
    Lincoln UK
    Hi Eddie ( again lol )
    I was thinking that today as I have been making sure all the connections were good.
    My main worry is trying to find a replacement if it's really bad.
    I've got no problem with marking it all up be for taking apart.
    Thanks for input.
     
  5. metalmelt Member

    Messages:
    595
    Location:
    UK
    Many companies do direct replacements.
     
  6. MBB Forum Supporter

    Messages:
    1,127
    Location:
    northumberland
    What is the coil voltage?
     
    ktis likes this.
  7. ktis New Member

    Messages:
    3
    England Birmingham
    220/240 v replaced the 480v today thanks for asking MBB my Murex 130 has come to life
     
Advertisements