Kemppi MinarcTIG Evo 200MLP

  1. metalworker New Member

    Messages:
    4
    Location:
    Norway
    recently bought a 2nd hand Kemppi MinarcTIG Evo 200MLP. the condition is pristine and it could weld any size electrodes all to my likings. the problem i am having with is on the TIG side. whenever i Tig weld, whether on 2T or 4T, and on any other settings, the set welding amperes would fall down from, say a setting of 110A to 5A in less than a 30 seconds or so. it can't hold the set amperes at all. in short, it can not weld on TIG. i don't know if it is the machine that has a problem or me who needs more training and knowledge about the right settings of the welder. i am ready to get this returned to the seller but i want some opinions first regarding the problem. if majority says i need to return the item then i will send it back but if i can get some help to get this working right then i will keep it. but of course i need somebody to help me out. thanks and hope to hear from someone else soon.
     
  2. Richard.

    Richard. Member

    Messages:
    18,093
    Location:
    Cambridgeshire
    Golden rule no 1 Try before you buy.
    So many people buy used machines and bizarrely don’t test them and then find a problem. I don’t know what’s causing your issues I’m afraid but it sounds like a fault.
    You wouldn’t have a second hand car delivered without looking and driving it first??
     
  3. bwservices Member

    Messages:
    381
    Location:
    Ireland
    id check is the torch switch working perfectly first
    change the downslope to minimum to rule out its not causing the fall
     
  4. metalworker New Member

    Messages:
    4
    Location:
    Norway
    thanks for the reply. i forgot to mention that i bought the machine online more of an ebay kind so it is hard to be sure. it is just like box of chocolates. you will never know what are going to get.
     
  5. metalworker New Member

    Messages:
    4
    Location:
    Norway
    thanks for the reply. the torch is working perfectly when used on the MasterTig AC/DC 2300MLS. and about the setting of the downslope and other settings that we can think of still not giving positive signs.
     
  6. Richard.

    Richard. Member

    Messages:
    18,093
    Location:
    Cambridgeshire
    Crackers!
    Oh well I’d contact the seller and at least mention your problem they may be prepared to help. Is it a genuine company or a private seller.
     
  7. metalworker New Member

    Messages:
    4
    Location:
    Norway
    good morning richard, it is a private seller and i have contacted the seller about the matter before christmas but unfortunately, he was to go for the lengthy vacation somewhere. he seems to be ok for the return of the item when he gets back from his leave. only thing i brought it up here on the forum is, there might be someone else who had the same issues and might be able to chime it. sometimes there are things we thought it was so big but in reality is just a push of a small button or a little change on the settings. it would still be good if this works so i don't have to go to the pain of packing and sending it back to him.
     
  8. Richard.

    Richard. Member

    Messages:
    18,093
    Location:
    Cambridgeshire
    That’s good news then that he will accept it back.
     
Advertisements