Help needed for information on my welder

  1. Stotty23 Member

    Messages:
    15
    Location:
    United kingdom - East Midlands - chesterfield
    I have a ferromatic spitfire 160 MIG welder I've tried to search the internet but I carnt find nothing at all I carnt even find a photo on Google images nothing at all I just want to no if anyone has herd of this welder if they no anything about it etc pictures attached received_10216158129291494.jpeg received_10216158134451623.jpeg
     
  2. pedrobedro

    pedrobedro Man at Matalan

    Messages:
    9,733
    Location:
    CX Derbyshire
    Never seen anything like it, hope someone can enlighten you on it's origin. There's a Ferromatik (with a K) company actually based in Chesterfield that makes plastic injection machinery. It looks a solid old machine, have you used it yet ?
     
  3. Wozzaaah

    Wozzaaah The wizard of woz Staff Member

    Messages:
    14,278
    Wiltshire, UK
    It’s not a name I’ve ever come across on here before. What do you need to know about it?
    Looks like it was probably a good machine in its day, ideally suited to car repairs.
     
  4. Stotty23 Member

    Messages:
    15
    Location:
    United kingdom - East Midlands - chesterfield
    I bought it last night I've switched it on thats about it so far I going to have a play with it today but I believe I got a bit of a good deal on it far as I no I payed £150 and it came with gas bottle regulator came with 2 euro torchs earth lead 2 spare regulators 5 welding moul grips to clamp work pieces some welding pliers and a box of consumables and reel of wire I just wanted to no if anyone had heard of the brand etc see what kind of price they are or was or if there any good and if I ever needed spares if it broke etc
     
  5. 500e

    500e Always buy fire insurance a flood is hard to start

    Messages:
    3,861
    Location:
    Somerset UK
    The gun looks a bit like the Tweco
    Photo of service plate may help
     
  6. Stotty23 Member

    Messages:
    15
    Location:
    United kingdom - East Midlands - chesterfield
    There's no writing anywhere on it to say like amps volts anything like that IMG_20180418_125623.jpg
     
  7. fixerupper

    fixerupper Member

    Messages:
    1,486
    Location:
    Crete Greece
    It looks like a good old well made machine that wire feed looks the business ...get it up and running if you google ferromatic 160 you get some oerlikon rutile rods ...:dontknow:
     
  8. cumbriasteve

    cumbriasteve Moderator

    Messages:
    9,660
    Location:
    Cumbria UK
    The name sounds Italian.

    Looking at the condition of the wire it's been in regular use or stored somewhere nice and dry, the fact you got the extras with it suggests it is someone packing up and not selling because it's rubbish.

    Lovely looking machine and a belter wire drive unit, if all is ok you have got a bargain there.
     
  9. Stotty23 Member

    Messages:
    15
    Location:
    United kingdom - East Midlands - chesterfield
    The person I got it of was a woman as her husabhu has just passed away unfortunately so she was getting rid of everything as the garage has been took down and she had this in her dinning room and needed it gone out the house I'm hoping it's nice to use and there no issues
     
  10. Ton-up

    Ton-up Member

    Messages:
    1,331
    Location:
    Essex, England.
    cumbriasteve likes this.
  11. Stotty23 Member

    Messages:
    15
    Location:
    United kingdom - East Midlands - chesterfield
    I've just been playing with it and seems a great welder but having bit of issue we wire feed sometine wire feed wheels are spinning on the wire and if I tighten the clamp parts on wheel then it dosnt move altogether etc sometime welds sound then other times it slips etc
     
  12. cumbriasteve

    cumbriasteve Moderator

    Messages:
    9,660
    Location:
    Cumbria UK
    Dirt on the rollers.
    Spool too tight on the drum
    Damaged or dirty liner.
    Wrong groove on the roller, they usually have two.
     
  13. Stotty23 Member

    Messages:
    15
    Location:
    United kingdom - East Midlands - chesterfield
    Spool is loose seems bit to loose sometime if it's on quick wire speed when u stop pressing button reel still spins a bit so wire goes slack on reel rollers seem clean and there's to grooves one but bigger than other tried it on both and still does it here and there
     
  14. Stotty23 Member

    Messages:
    15
    Location:
    United kingdom - East Midlands - chesterfield
    Is it normal to have power set to like 5/6 and wire speed only on 3 out of 10 seems only place it welds nice owt more just splutter and pops etc I thought 3 on wire speed sounds a bit low with it on setting 5/6
     
  15. cumbriasteve

    cumbriasteve Moderator

    Messages:
    9,660
    Location:
    Cumbria UK
    I have a good way of understanding the wire speed numbers...I ignore them, if it's welding nice then the speed is right and the numbers can say whatever they like. :laughing:
     
    Stotty23 and eLuSiVeMiTe like this.
  16. Wozzaaah

    Wozzaaah The wizard of woz Staff Member

    Messages:
    14,278
    Wiltshire, UK
    Sounds like the torch probably needs a service.
    New liner and contact tip will allow the wire to go through with less resistance.
     
Advertisements