Compressor not firing up

  1. CT85 Member

    Messages:
    29
    Location:
    Northern Ireland Armagh
    Evening all while in my shed this evening my compressor was filling up and rushing as usual I turned it off at the mains while it was still filling it didn't sound to good now it won't turn on anyone any idea what's wrong thanks in advance for any replies.
     
  2. gordon stephenson

    gordon stephenson Forum Supporter

    Messages:
    6,850
    Location:
    Skelton in Cleveland U.K.
    Blown or tripped fuse?
     
  3. Ruffian Member

    Messages:
    2,429
    Location:
    Devon UK
    Reset button in the black housing above the motor?
     
    CT85 likes this.
  4. WorkshopChris

    WorkshopChris Forum Supporter

    Messages:
    4,925
    Location:
    South East Essex
    Did you turn it off via the red button on the pressure switch to releases the pressure between the tank and piston before you tried to restart it.
     
  5. julianf

    julianf Member

    Messages:
    4,719
    Location:
    devon, uk
    Drain the reciever of air also. My bet is it's the cold.
     
    CT85 likes this.
  6. CT85 Member

    Messages:
    29
    Location:
    Northern Ireland Armagh
    Haven't looked at it yet had to leave the shed in a rush will check it tomorrow
     
  7. CT85 Member

    Messages:
    29
    Location:
    Northern Ireland Armagh
    Will take a look tomorrow cheers lad
     
  8. CT85 Member

    Messages:
    29
    Location:
    Northern Ireland Armagh
    Yeah Chris no joy will get a proper look at it tomorrow let ya's know we're I stand
     
  9. CT85 Member

    Messages:
    29
    Location:
    Northern Ireland Armagh
    Ruffian you were right it was the reset bottom on the black housing never even new it was there lol cheers bud
     
Advertisements