Butter/Javac 200AC/DC---NO SPARK---

  1. Tintown New Member

    Hello i bought a butters/javac 200 AC/DC from DIYWelding last January (2008) and last month when i was welding brass my machine stopped working. I had run out of Argon halfway through, so i connected the bottle of Argoshield from my mig and within 5 minutes my welder stopped working. I still get a readout on the LED display as to how many amps i am running, but i dont get any spark from the torch. I have checked the earth lead which is fine and then put in the stick (MMA) which is also not giving me any spark. Do you think did the gas do it, i read somewhere that argoshield does not give the same cooling properties, and i think i saw the temperature LED on, also it says gas cooled at the back of my machine. DIYwelding tell me the warranty runs out after a year, so i dont want to send it to them. Anybody got any ideas what has happened and how i can solve the problem.

    Thank you for any help
  2. malcolm

    malcolm Administrator Staff Member

    Posts: 8,195
    Bedford UK
    Have you tried removing the tungsten and collets and giving them a good clean? Also change the tungsten. Argoshield is not an inert gas so will quickly corrode the tungsten and anything else that gets very hot.
  3. Butters Member

    If the temperature LED was illuminated it means that the machine needs to cool itself down...you will not get the machine to give any output until it has cooled down and the LED goes out. During this time you will hear the fans running to assist in cooling the internal components..do not turn the machine off, leave it switched on, as some internal bits and pieces may get damaged by not allowing it to cool.
    Are you sure the LED illuminated is the over temperature one. If its the other red LED then the machine definately needs looking at....major failure.
    To check your earth fully - Try putting the earth lead on your MIG set (if it has the same plug/socket) and make sure your get sparks with your MIG, this will prove the earth is ok.
    If still no joy set the machine up for TIG, DC, 2T, and make sure the remote switch is in off position. Then just trigger the torch....Can you hear a relay click inside the machine ? Can you hear the gas solenoid valve click at the rear of the machine ? If not you are going to have to get someone to have a look at the machine. No ones going to do it for nothing, unfortunately, but I do know a specialist (Butters Original) who will be able to give more guidance and a quality repair job , if required.......
  4. Rwm New Member

    Posts: 4
    UK
    Hi there Tintown,

    I'm having the exact same bother with my JAVAC tig welder, I have checked all the familiar stuff my self, and have had a Electronics expert look at the welder but still no joy.
    Did you manage to find out what the problem was with your one?
    I see that JAVAC have started trading again under the name JAVAC Deutschland so I was going to drop them an e-mail.

    Thanks,

    Ryan.
  5. Wozzaaah

    Wozzaaah The wizard of woz Staff Member

    Hi Ryan, Tintown hasn't been online since he started this thread 5 years ago so your best bet is to start a new thread of your own in the Butters section giving us as much detail as possible.
    Someone on here may be able to help you out.
  6. Rwm New Member

    Posts: 4
    UK
    Thank

    Thanks for that info Wozzaaah, I will start a new thread.
Recent Posts