Thermalarc 190 gts hf

  1. Paul Brown New Member

    Messages:
    5
    Location:
    Uk
    Hi guys I have just acquired a 190 gts I'm new to welding I have set machine up but can't get hf start to work I have to touch the work piece to get an arc I have tried torch with a button and foot pedal. The plug on the torch only has 2 prongs and the foot pedal has 7 could this be the problem? Sorry if it's a stupid question like i say just new to this.
    Paul.
     
  2. 500e

    500e Always buy fire insurance a flood is hard to start

    Messages:
    4,567
    Location:
    SWest UK
  3. Paul Brown New Member

    Messages:
    5
    Location:
    Uk
    Hi the machine has hf and lift start tried it on both settings still only arcs when I touch the workpiece
     
  4. carbon

    carbon Member

    Messages:
    1,551
    Location:
    S. Glos. U.K
    I believe on some of the thermal arc machines there is an arc gap inside the machine case that needs to be set correctly to get hf working.
     
  5. Tigman

    Tigman Forum Supporter

    Messages:
    2,904
    Location:
    Watford UK
    Paul have you set the hf switch to on position ? then it looks like you have to set HF on the hot start knob , crank it up and see what that does !
     
  6. 500e

    500e Always buy fire insurance a flood is hard to start

    Messages:
    4,567
    Location:
    SWest UK
    Or are you saying the TIG does not work at all
    Sorry about link I see ESAB has screwed the site with adverts, I hate corporates you used to be able to find most of the TA info there
     
  7. Paul Brown New Member

    Messages:
    5
    Location:
    Uk
    Tried that tigman still nothing.looks like I'm gonna have to have someone look at it thanks carbon.
     
  8. Paul Brown New Member

    Messages:
    5
    Location:
    Uk
    Hi 500e the tig works but only on lift start put it on hf and still only on lift start
     
Advertisements