Murex tradesmig 165 lacking power

  1. Spark plug

    Spark plug Member

    Messages:
    3,781
    Location:
    Durham, England
    A friend of mine has just bought a tradesmig and brought it to me to test as he has no gas yet.

    I’m told it had been stood for a long time as it came from a retired car restorer who had to stop due to ill health. The wire was rusty, so pulled that off then gave it a test and it is severely lacking power, you can just about weld with the voltage set to maximum but it’s defiantly not right.

    F52B71BA-DA4A-48DD-9F4F-7FC96873FE87.jpeg
    this is what happens when set to minimum voltage, never seen anything like it:
    E6A29ABE-0418-43A3-8403-0EF61FB84870.jpeg

    I’ve checked the earth and tried another torch, anyone got any ideas?
     
  2. hotponyshoes Member

    Messages:
    3,399
    Location:
    Somerset. Uk
    Measure the voltage between the torch and return, see if it changes as you move the power selector switch
    Check continuity of the torch power lead and return lead
    Check the inside of the contact tip is not rusty
     
  3. Wozzaaah

    Wozzaaah The wizard of woz Staff Member

    Messages:
    15,197
    Wiltshire, UK
    A faulty rectifier diode will cause lack of power.
     
  4. Spark plug

    Spark plug Member

    Messages:
    3,781
    Location:
    Durham, England
    All good stuff chaps, I’ve given in for the night, I will have another look tomorrow.
     
  5. andymfell Member

    Messages:
    176
    Location:
    cumbria uk
Advertisements