I've been lent a Corsa..

  1. Chillitt Member

    Messages:
    1,039
    Location:
    Cirencester
    Of course it doesnt go..
    Well it goes, but only starts on easy start... runs sweet as a nut once coaxed into life
    Its a 2004 Ecotek 1.4 diesel common rail. Fuel pump in tank works a treat, fuel filter not blocked. Its seems to be a cut off valve or similar because spinning it over on the key it doesnt make any effort ot fire, but once the easy start catches it fires right up. Needs help every time, even if its just been stopped. I know next to nothing about common rail engines. Can anyone suggest a good forum without me having to deal with the boy racers, or software to go with my OBD reader and the laptop? Its just arrived today so Im starting from scratch, no manual or anything.. need to get it starting properly as it will need an MOT soon
    [​IMG]
     
  2. qwakers Member

    Messages:
    429
    Location:
    cornwall, united kingdom
    fuel pressure sensor, id put my money on it.
     
    tom2207 and Ruffian like this.
  3. Melvyn Best Member

    Messages:
    431
    Location:
    Cambridge
    Ive had several vehicles with exactly the same symptoms that have been caused by faulty fuel pressure regulators in the fuel rail, some are available as a separate part from diesel specialists, some only available with the fuel rail .
     
    zx9 likes this.
  4. Dcal

    Dcal Forum Supporter

    Messages:
    2,014
    Location:
    Antrim Northern Ireland
    TDC sensor?
     
  5. qwakers Member

    Messages:
    429
    Location:
    cornwall, united kingdom
    if ot was it wouldnt run at all
     
    james butler likes this.
  6. qwakers Member

    Messages:
    429
    Location:
    cornwall, united kingdom
    possibly, ive had both the pressure sensor and the regulator cause the same fault in the past.
     
  7. bletchmonster

    bletchmonster Member

    Messages:
    447
    Location:
    Cheshire. England.
    In my experience, it could be jiggererd injectors reducing fuel pressure.
     
  8. Dcal

    Dcal Forum Supporter

    Messages:
    2,014
    Location:
    Antrim Northern Ireland

    I’ve had a couple of cars where they won’t start reliably but run perfectly and it's been the TDC sensor.
    Very common fault on fiats and alfas but the normal fault is they won’t restart when hot because the sensor goes OC when hot.
    Read the codes and see what's stored.
     
  9. Melvyn Best Member

    Messages:
    431
    Location:
    Cambridge
    I think your going to have to get some live data or maybe a leak back test?
     
  10. wacky7791

    wacky7791 Member

    Messages:
    168
    Location:
    SEQ australia
    pretty sure tech 2 is the diag software for vaux/opels, be cheaper to put a generic code reader on initially just to see if any codes come up.
     
  11. Chillitt Member

    Messages:
    1,039
    Location:
    Cirencester
    Yes, trying to find the software to hook the laptop up that doesn't cost more than the vans worth..
     
    wacky7791 likes this.
  12. qwakers Member

    Messages:
    429
    Location:
    cornwall, united kingdom
    vaux-com
     
  13. Chillitt Member

    Messages:
    1,039
    Location:
    Cirencester
    700 quid..
     
  14. wacky7791

    wacky7791 Member

    Messages:
    168
    Location:
    SEQ australia
    for generic code reading I use an ELM327 adapter and torque pro app which seems to work fine on most cars for basic code reading and clearing and some live data, had vag com for vw audi, I have one called 'op com' somewhere which is supposed to do vauxhall, opel and saab but I've never tried it. cheaper than tech 2 or vaux com BUT no idea how good it is, they're available on ebay.
     
    Chillitt likes this.
  15. premmington

    premmington Member

    Messages:
    1,662
    Location:
    Norfolk
    That would be my guess too.

    I would want to be reading the rail pressure on live diagnostics against cranking speed.

    You want Minimum 280bar at 250rpm to start (it will try and fire at 250bar thou).

    Then i would have the bottles out to see which injector it was that had excessive leak back.


    I have changed thousands of rail pressure sensors - CR pump metering valves on Fords/Jags/Land Rovers - or anything with Renault 1.5DCi engines. But never on GM 1.4 engine.


    That looks a "proper little van with a roof rack" from the photo - well worth an injector. Grease the complex handbrake cable system up and away you go.
     
    Chillitt likes this.
  16. frank horton

    frank horton V twins are great but 4"s rule.........

    Messages:
    1,848
    Location:
    Soon 2 B Crete
    just hope after all that Easy Start it wont need it once the carp electronics are sorted.......
    mostley once on easy start they are hooked on it.....bit like a druggy.......
    Beside unless ur very lucky it'll cost more to fix than it's worth......
    shame cos it don't look like the normal rust bucket.......!!!!!
     
  17. qwakers Member

    Messages:
    429
    Location:
    cornwall, united kingdom
  18. premmington

    premmington Member

    Messages:
    1,662
    Location:
    Norfolk
    I don't use easy start. Never have done. I might at a push spray one squirt of brake cleaner into a diesel to see if it fires "on time" for a non runner - prove if it is a fueling fault.

    I hate the excessive noise of detonation when they bang off on Ether (not sure but I think easy start is Ether?).


    Yeah I thought the van looked OK from photo - I would drive it about.
     
    Wallace and Ruffian like this.
  19. Chillitt Member

    Messages:
    1,039
    Location:
    Cirencester
    I'm always circling the pug hole of 'Thats not worth fixing.. ' My Transit is in the process of finally crossing the line. (By any sensible measure it crossed that line last year with the second engine swap.) There is another van in the offing so this may or may not tide me over..
     
  20. Chillitt Member

    Messages:
    1,039
    Location:
    Cirencester
    Generally, nor do I but this van has turned up with a can and the info that thats the only way to start it. Im trying to ween it off now. First issue Ive found is none of my laptops will fire up so the software thing is slipping down the list.. Plate spinning.. there is a rail with both sensors on ebay for 30 quid, which I might go and have another look at..
     
Advertisements