Colchester bantam feed not working

  1. ajmoore1 Member

    Messages:
    64
    uk
    Hi guys

    Hoping one of you knowledgeable chaps maybe able to help me. I am still learning to use my lathe and think I may have damaged it. I was doing a cut with the feed and set the stops on the carriage to stop at same place. The idea being to stop the feed just before the stop then hand wind to the stop. Unfortunately I couldn’t disengage the feed before it hit the stop so I hit the e button. I could disengage the feed lever as it was tight against the stop. I managed to wind the stop in and disengage the feed.

    Since this happened the feed does not work. I have taken the end cover of the drive end and the cogs are all driving(it runs when the cover is removed). I have read that there is a shear pin but I think that hasn’t sheared and it’s something in the bottom gear box. Pics below if any help. The pic of the drive end was taken when the lathe was running and all cogs were turning but the feed screw wasn’t. I hope I haven’t damaged it beyond repair.

    cheers in advance

    upload_2020-2-12_18-46-19.jpeg

    upload_2020-2-12_18-44-44.jpeg
     
  2. Brad93

    Brad93 M J B Engineering

    Messages:
    6,622
    Location:
    Essex
    That gearbox needs to come apart
     
  3. MBB Forum Supporter

    Messages:
    833
    Location:
    northumberland
    Make sure the selector levers are engaged properly.
     
  4. ajmoore1 Member

    Messages:
    64
    uk
    Done that. Played with all the levers but nothing.
     
  5. citizen kane Member

    Messages:
    166
    UK Hampshire
    I'm pretty sure that the Bantam is much like the Chipmaster, if it is the feed should automatically knock out when it hits the bed stop, if for some reason it dosnt then the shear pin should protect the gearbox, couldn't help but notice that you have the lead screw dog clutch engaged, where you feeding off the lead screw?
     
  6. citizen kane Member

    Messages:
    166
    UK Hampshire
    My mistake, lead screw dog clutch is disengaged.
     
Advertisements