Cebora Auto Star 180 ( Art 838 ) PCB dead !?

  1. Bonzo Member

    Messages:
    8
    Sw Cornwall - UK
    Hi all

    Second post & in need of help so soon :o

    The PCB on my ederly Cebora Auto Star 180 ( Model: 838 )Mig welder, looks to be dead :(

    Here's the story so far.

    A couple of years back the wire feed became erratic( Feeding wire at full rate ), it was noticed that if the wire speed knob was wiggled a little, the wire feed would work normally for a short while.

    It came to the point that unless pressure was held on the knob, I could not controll the wire feed rate ( Flat out once more )

    Not being a complete numty when it comes to electronic work, I removed the PCB, de-soldered the board's potentiometer & gave it a good clean with some low pressure compressed air.
    I noticed that the pot had started to come appart .... In hind sight, I guess this would have been the ideal time to replace the thing :ashamed:
    So much work on at the time I needed it fixed quick as downtime would have been costing me a bundle :o

    Anyway, back to the story.
    I re-soldered the potentiometer back on to the board, when I fitted the Red mounting collar I placed a small non conductive washer between the collar & pot.
    This made sure a little pressure was exerted on the pot.

    The welder worked without fault for almost 2 years untill recently, went to use the set & the old problem had returned .... Wire feeding at full rate, the control knob had no effect.

    Cock sure that the potententiomter was faulty a new one of the same value was bought .... Well 2 because I was unable to determine if I needed a linear one or a log one !!??

    Fitted the linear pot first .... The welder was still the same, wire feeding at the full rate.
    I then fitted the log pot, this gave me some tiny degree of wire controll but only on a tiny part of the pots range .... only a few mm or so.

    So at this point, unless I was welding on full current, the mig welder was next to useless to me :(

    After spending many hour's searching the internet, I came uppon a welder PCB repair service & promptly sent the board off for a professional repair.

    Best point out at this stage that when the board left me .... On the face of things all was well except the wire feed problem !!??
    The board was still swiching both the welders main contactor relay & still switching the shielding gas.

    The board was gone from me for a good few weeks & was returned as a fully repaired board, earlier this week, not worried about the repair time as I know how difficult it can be to source parts at times.

    Oh deep joy .... At last I can get back to the work on my kit car project :clapping:

    Imagine my dissmay when I fitted the board back in the welder, just to find that it was now completely dead :o
    The board is now not swiching the power, gas or wire, all I get now when I press the trigger on the torch is a click from the relay on the PCB :(

    Checked for loose connections but none found.

    Does any kind soul on here have a schematic diagram for this board ?

    I know the set is about 20 years old but it has been a good servant to me, simply just don't want to stick it on ebay for spares or repair .... Not in me to do that if it can't be fixed & cant bear to chuck it in the skip :(

    Sorry for the long, long post but I find it best to give the full story at the outset .... Help others to help me & all that :cool:
     
  2. eddie49 Member

    Sounds as though the initial problem was a lack of contact between the rotating slider of the pot and the resistive track. With it being available in log, I guess it is a carbon pot, not a wire-wound.
    Then the second problem ( limited adjustment range ): are you sure you selected the correct ohms value for the replacement part ? Or maybe something in the control circuit got tired of being intermittently open, and died.
    The last problem - relay clicks but does not activate anything : are you sure that the "repaired" PCB has been wired back in to the welder correctly ? If it has, then I'd start by tracing the wiring on each side of the relay contacts. Should have 12 or 24 V, or possibly mains, on one side, and go to the main contactor and the gas solenoid on the other side.
     
  3. Bonzo Member

    Messages:
    8
    Sw Cornwall - UK
    Hi Eddie

    Thanks for your reply.

    I am almost certain that the original & replacement pots were the same.
    The only marking on the original pot was 2K2 , after a bit of research I understand that this relates to a pot value of 2.2 k ohm's

    The replacement pot other than being Blue in colour was identical to the original.

    On this PCB it would be impossible to install wrong .... 1 Single mounting screw thru the front panel to monut the board & a 8 pin, idiot proof plug to plug in ( Impossible to connect the wrong way round )

    I did send the original pot to the boards repairer just to ensure that I had fitted the right part + The full history of the problem.

    The board came back with a couple of components replaced but the pot I fitted is still on the board.
    I have contacted the repairer but as yet, have not had any reply.

    Thanks or the testing info, I never bothered to get the multi meter out as I wouldn't know what values to look for & where to test.

    Spent ages lookig for a schematic drawing for the board on the net but none to be found :(

    Here's a picture of the PCB, I have marked the three components that have been replaced by the repairer.

    The only id on the board is: ( LS ) 5600923

    Thanks again, Ronnie
     
    • PCB.jpg
  4. eddie49 Member

    Ronnie,
    I can't actually make out which of the three components have been marked....
    As you say, with the 8-pin plug, the PCB must be wired-in correctly. Maybe worth using the meter to see what is on all of those 8 pins, between them and earth, and between each other. Try this with power on, and then with the torch trigger pressed. Be careful, just might be mains around there... [ You could get a better idea if that is the case by looking at what is marked for the coil voltages on the main contactor and the gas solenoid.]
    For the relay on the PCB to click when you press the torch trigger, there must be "auxiliary power" coming to the board - usually 12 or 24 v, possibly as AC, from a small transformer. That power source often runs the wirefeed motor too ( rather than taking it's power from the main welding transformer ), but in your case neither the main contactor, the gas solenoid, nor even the wirefeed get power when the trigger is pressed.
    As part of the troubleshooting process, if the contactor can be manually operated ( square black plastic button in the centre ), try pressing the torch trigger and that button at the same time. Does the torch tip go live with welding power ?
     
  5. mr migwire

    mr migwire It's more fun with metal.

    Messages:
    1,813
    Location:
    fife
    had to import it and zoom in to see the red squares...

    chip on right of board, upper of the 2 voltage regs on the left and what looks like a thermistor in the middle just above the relay.

    all are marked with deep red sqaures arond them......;)
     
  6. mr migwire

    mr migwire It's more fun with metal.

    Messages:
    1,813
    Location:
    fife
    cebora@cebora.it

    this is ceboras email addy, i would imagine they would sort you with a schematic for your board mate.
     
  7. Bonzo Member

    Messages:
    8
    Sw Cornwall - UK
    Cheers mr migwire

    Yes one of the voltage regs was changed .... TIC126D

    The one just above the relay in the centre looks to be a similar component to a voltage reg ( 3 pin with an eye for fixing to board or heatsink ). Can't read the markings as they face the relay.
    Either a used part or has been removed for testing !!??

    The through board 14 pin IC has been removed, a new 14 pin holder has been fitted & a new 14 pin LM324N IC has been fitted .

    Thanks for the test procedure details eddie :cool:

    Here's a slightly clearer picture ( sorry about the text size )

    Thank's so much for the help chaps :hug::cool:
     
    • PCBa.jpg
  8. mr migwire

    mr migwire It's more fun with metal.

    Messages:
    1,813
    Location:
    fife
  9. Bonzo Member

    Messages:
    8
    Sw Cornwall - UK
    Yes mr migwire it certainly looks the same .... First thing I done whe I bought it was to fit a euro socket & decent torch.

    I seem to remember it cost me a small fortune at the time :o

    Will try to get out to the worshop tomorrow, get the test meter out & have a delve into the Cebora.

    Was so annoyed that the welder still didn't work, I headded up to BOC to see if I could get a new PCB & came home with a new welder instead :D:D

    To be on the safe side .... I did phone the Mrs up to see if it was safe to come home :o:whistle:

    Just hate being defeated by electronic problems ;)
     
  10. mr migwire

    mr migwire It's more fun with metal.

    Messages:
    1,813
    Location:
    fife
    i know what you mean, i had a search around on ceboras website but they dont seem to list your model in there back catalouge, maybe its 2 old :laughing:

    i have posted up there email address there is also contact numbers on there website.

    ive got a boc mig thats about 20 years old and only welds on full power but i would never part with it. mabe one day i will get round to fixing it but my sealy 185 does everything i need so while thats still going the boc can languish in the shed;)

    http://www.cebora.it/ing/indexc.htm :waving:
     
  11. Bonzo Member

    Messages:
    8
    Sw Cornwall - UK
    Morning chaps

    Good morning to you all :cool:

    mr migwire, thank's for Ceboras contact details, i'll get an email off to them next week .... You never know, they may oblige me with a schematic of the PCB :whistle:

    I would say that the welder is every bit of 20 year's old now :o

    Been out in the workshop this morning & have done some of the testing that eddie sugested, as far as I could tell all is well with everything bar the PCB.

    After tracing the PCB tracks & looking at the data sheet for the IC, I became convinced that the LM324N chip had been placed in the holder the wrong way round !!??

    Bit the bullet and swapped it arround .... Well you can't really break something that is broken, right :D:D

    Switched the welders power back on, nothing exploded .... So far so good.
    Pressed the trigger on the torch, hey presto .... Wire feed, gas flow & main contactor relay working :welder:

    As for the wire feed problem it is only fractionally better than when I sent the PCB for repair :(

    When the wire speed controll knob is turned I get nothing untill I reach setting 1.5
    At 1.5 the wire starts to feed at its slowest rate, buy the time I hit 2, the wire is feeding flat out !!

    More or less back to square one .... Welder is useable but personally, I can't live with it like that :o

    My only thoughts are, is it likely that the new IC has been damaged by installing the wrong way round & is it likey that the new TIC126D Thyristor has been damaged also !!

    Cheap enough components to buy, guess it couldn't hurt replacing them.

    Another thought is the potentiometer .... The board is still fitted with 2.2k ohm log type pot.
    Would it be worth trying the linear one, once again.

    I understand the theory behind linear & log but in real world terms, I do not have a clue as to what effect each type will have on a electronic circuit :ashamed::ashamed:

    Well that's the story so far folks
     
    Last edited: Jul 10, 2010
  12. mr migwire

    mr migwire It's more fun with metal.

    Messages:
    1,813
    Location:
    fife
    i would try replacing the ic first mate, if the volt reg isn't showing any signs of external damage i would hazard a guess its ok, they are pretty hardy,

    then again for the price of replacing them it wouldnt hurt, defo try the ic first though.

    i once repaired a mig for my mate, it to was spooling out the wire full pelt and it turned out to be a resistor that caused the fault,

    atleast your making headway mate:clapping:
     
  13. mr migwire

    mr migwire It's more fun with metal.

    Messages:
    1,813
    Location:
    fife
    just had a thought and nipped up the loft for a look see and hey presto...............5x LM324N analouge ic's.:clapping:

    i used to be a radio amateur but i'm ok now:laughing:

    bonzo pm me your adress details and i will send you a couple down:D

    sorry but all the voltage regs ive got are rather heavy duty and wouldnt suit ;)
     
  14. Bonzo Member

    Messages:
    8
    Sw Cornwall - UK
    Thanks for that, I have sent you a pm :cool:

    Absolutely determined to get to the bottom of this fault ;)

    At least you used to be a professional Radio ameteur .... The best I could do was an old am/fm CB radio .... 1:4 for a copy & all that :ashamed::ashamed::D:D

    Many, many thanks for your help :cool:
     
  15. mr migwire

    mr migwire It's more fun with metal.

    Messages:
    1,813
    Location:
    fife
    dont knock it mate ive still got a 40box in the van :ashamed:

    although these days all i here on it is eastern european chatter:o

    sounds like there planning an invasion:laughing:
     
  16. R Kraft Member

    Messages:
    978
    Wyoming,USA
  17. allan6484 New Member

    Messages:
    1
    sunderland uk
    autostar 180 mig welder.. power control problem help?

    hi all i'm new to this so excuse me if i dont understand short text meanings..
    i recently bought a cebora autostar 180 mig welder so i could learn how to weld and to rebuild my fiesta rs turbo project.. i tested the welder b4 i bought it and it seemed to work fine.. however when i came to weld the car i was trying to fill in a few pinholes but the welder is just making the hole bigger. got power turned right down but doesnt make a difference. the green light above the power control dial isnt on so i believe this to be at fault... does anyone know where i could get a spare from and do you's think that is the fault? thanks. :)
     
  18. heskencren Member

    Messages:
    5
    Location:
    Kernow, UK
    Hi, It looks like we were having problems with the same circuit board around the same time although mine was BOC.
    http://www.mig-welding.co.uk/forum/threads/boc-automaster-185-wire-feed-control-probs.17061/
    Must be the Cornish weather!
    I made the link to your thread as now I have the board out I also have that part number (LS) 5600923.
    Did you resolve the problem. Mine has been intermittent. A hair dryer was curing it then I put the circuit in a bag with silica gel sachets. I think the potentiometer is worn. It is 2k2 330M may be carbon track as def not wound. Was your potentiometer log or linear in the end?? Also need source of good replacement. Mine had nice heavy duty double contacts. Also was your chip as below??
    boc chip.jpg boc pot.jpg
    Thank you.
     
Advertisements